PTA 团队天梯赛║L2-003 月饼

一、题目要求

月饼是中国人在中秋佳节时吃的一种传统食品,不同地区有许多不同风味的月饼。现给定所有种类月饼的库存量、总售价、以及市场的最大需求量,请你计算可以获得的最大收益是多少。

注意:销售时允许取出一部分库存。样例给出的情形是这样的:假如我们有 3 种月饼,其库存量分别为 18、15、10 万吨,总售价分别为 75、72、45 亿元。如果市场的最大需求量只有 20 万吨,那么我们最大收益策略应该是卖出全部 15 万吨第 2 种月饼、以及 5 万吨第 3 种月饼,获得 72 + 45/2 = 94.5(亿元)。

输入格式:

每个输入包含一个测试用例。每个测试用例先给出一个不超过 1000 的正整数 N 表示月饼的种类数、以及不超过 500(以万吨为单位)的正整数 D 表示市场最大需求量。随后一行给出 N 个正数表示每种月饼的库存量(以万吨为单位);最后一行给出 N 个正数表示每种月饼的总售价(以亿元为单位)。数字间以空格分隔。

输出格式:

对每组测试用例,在一行中输出最大收益,以亿元为单位并精确到小数点后 2 位。

输入样例:

1
2
3
3 20
18 15 10
75 72 45

输出样例:

1
94.50

二、解题思路

本题要想得到最大利润,一定要先卖单价高的月饼,因此创建一个月饼的结构体,存储其库存,总售价以及单价,根据输入的库存及总售价计算出单价。利用 sort() 函数按照各类月饼的单价降序排序,最后根据市场的最大需求从前向后遍历月饼数组,计算收益。

三、代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
#include <bits/stdc++.h>
using namespace std;

struct mooncake {
float stock; //库存
float totalsale; //总售价
float price; //单价
};
bool cmp(mooncake m1, mooncake m2) {
return m1.price > m2.price;
}

int main() {
int n;
cin >> n;
int demand;
cin >> demand;
struct mooncake mc[n];
for(int i=0; i<n; i++) {
cin >> mc[i].stock;
}
for(int i=0; i<n; i++) {
cin >> mc[i].totalsale;
mc[i].price = mc[i].totalsale / mc[i].stock;
}
sort(mc,mc+n,cmp);
float sum = 0;
for(int i=0; i<n; i++) {
if(mc[i].stock <= demand) {
sum += mc[i].totalsale;
}
else {
sum += mc[i].price * demand;
break;
}
demand -= mc[i].stock;
}
printf("%.2f\n",sum);

return 0;
}

四、反思总结

C++中的 sort() 函数十分好用

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
// 语法
sort(start,end,cmp)
// 参数
1)start 表示要排序数组的起始地址;
2)end 表示数组结束地址的下一位;
3)cmp 用于规定排序的方法,可不填,默认升序。

//示例一 sort 函数没有第三个参数,实现的是从小到大(升序)排列:
#include<iostream>
#include<algorithm>
using namespace std;
int main()
{
int a[10]={9,6,3,8,5,2,7,4,1,0};
for(int i=0;i<10;i++)
cout<<a[i]<<endl;
sort(a,a+10);//指针
for(int i=0;i<10;i++)
cout<<a[i]<<endl;
return 0;
}

//示例二 加入一个比较函数 compare(),实现从大到小(降序)排列:
#include<iostream>
#include<algorithm>
using namespace std;
bool compare(int a,int b)
{
return a>b;
}
int main()
{
int a[10]={9,6,3,8,5,2,7,4,1,0};
for(int i=0;i<10;i++)
cout<<a[i]<<endl;
sort(a,a+10,compare);//在这里就不需要对 compare 函数传入参数了
for(int i=0;i<10;i++)
cout<<a[i]<<endl;
return 0;
}

//示例三 有一个 node 类型的数组 node arr[100],想对它进行排序:先按 a 值升序排列,如果 a 值相同,再按 b 值降序排列,如果 b 还相同,就按 c 降序排列。就可以写一个比较函数:
bool cmp(node x,node y)
{
if(x.a!=y.a) return x.a<y.a;
if(x.b!=y.b) return x.b>y.b;
return x.c>y.c;
}